Support

Frequently Asked Questions

Is Aquaria compatible with OS X 10.5?

Last Updated Nov 17, 2008

It sure is.  Aquaria is OS X native, but does require OS X 10.3.9 or later.

Related question(s):

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account