Support

Frequently Asked Questions

Is Bubble Trouble X compatible with OS X 10.5 - Leopard?

Last Updated Sep 12, 2005

Bubble Trouble X is compatible with Mac OS X 10.3.9 and higher, including 10.5 - Leopard. 

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account