Support

Frequently Asked Questions

I updated the version of Deimos Rising that came preinstalled on my computer but now I get errors when I try to play - what can I do?

Last Updated Sep 13, 2005

Be sure you used the "DeimosRising bundle update" file to update the version of Deimos Rising that shipped with your computer.  The "DeimosRising update" file will not work for the bundled version of Deimos Rising. 

The only way we've been able to reproduce any errors with the bundle update is to install the updater files into the wrong location.  Be sure you have placed the "Deimos Bundle Update" file into the Deimos Rising folder and the HID.bundle into the data folder.

If you still have a problem, the only workaround is to reinstall Deimos Rising using the software restore CDs that shipped with your machine and then update using the "DeimosRising bundle updater".  Since there were many iterations of the Restore CDs, we do not have explicit instructions how to restore only Deimos Rising. 

Once you have restored the bundled version of Deimos Rising, use the "DeimosRising bundle updater" to update to the 1.0.6 version.

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account