Support

Frequently Asked Questions

I am trying to install the latest version of Dragster, but it will not let me - what can I do?

Last Updated Oct 27, 2006

Be sure you meet the minimum System requirements. Dragster requires 10.4 or later.

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account