Support

Frequently Asked Questions

Why can't I use Dragster on 10.4 any more?

Last Updated Dec 21, 2011

Support for Mac OS X 10.4, Tiger was dropped with the release of Dragster 1.1.3. Tiger users can download version 1.1.2 here.

Related question(s):

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account