Support

Frequently Asked Questions

Is EV Override OS X native, will it ever be?

Last Updated Sep 19, 2005

EV Override is not OS X native. EV Override requires a Macintosh running OS 7, 8 or 9.

EV Override and its sequel, EV:Override, have been released as plug-ins for EV Nova. EV Nova, available at http://www.ambrosiasw.com/games/evn/ has been ported to Windows and is also OS X native.

So if you are a registered owner of EV Nova, you can use EV Nova to play any and all of the EV Override games on PC or on OS X.

Related question(s):

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account