Support

Frequently Asked Questions

Why does Soundboard no longer work on OS X 10.5 or 10.6?

Last Updated Jun 25, 2012

In order to move the product forward, support for Mac OS X 10.5 and 10.6 has been dropped. The current version of Soundboard and any updates that follow will require Mac OS X 10.7.4 or later.

Existing Soundboard users still running Mac OS X 10.5 can download Soundboard 2.1.0 here.

Existing Soundboard users still running Mac OS X 10.6 can download Soundboard 2.2.1 here.

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account