Support

Frequently Asked Questions

Is Uplink compatible with OS X 10.5 - Leopard?

Last Updated Sep 14, 2005

Uplink is OS X native, but does require OS X 10.3.9 or later. Uplink is compatible with Leopard - Mac OS X 10.5. It is also a Universal Binary and will run native on Intel based Macs.

Was This Answer Helpful?

Not The Right Answer?

Copyright © 2013 Ambrosia Software, Inc. | All rights reserved worldwide. | Privacy Policy | Site Map | My Ambrosia Account